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ABSTRACT 

Structural equation modeling evaluates how well a theory in the form of a model fits data. Models might involve a 
number of interrelated variables and include latent variables, which cannot be measured directly, along with other 
variables that are directly measured. A new application, SAS

®
 Structural Equation Modeling for JMP

®
 1.1, features a 

graphical model builder that is useful for creating these interrelated models. The user interface appears in JMP 
software, and the calculations are performed by the SAS/STAT

®
 CALIS procedure. You create models by dragging 

variables onto a diagram, perform the analysis, and save and reuse the results. 

INTRODUCTION 

A structural equation model can be as simple as a regression model of a single predictor, or it can involve a number 
of interrelated variables.  In addition to variables that can be directly measured, such as height or weight, structural 
equation modeling (SEM) also accommodates the inclusion of variables that cannot be measured directly, called 
latent variables. For example, consider the concept of intelligence. It cannot be measured as height or weight can.  
You can use an IQ test score to represent intelligence, but an IQ test is an imperfect measure of the concept of 
intelligence.  One advantage of SEM is that you can incorporate measurement error into a model. 

SAS/STAT software has offered the CALIS procedure, which uses commands to perform SEM, since SAS/STAT 6. 
For elaborate models, a graphical specification can be more helpful. Integrating SAS and JMP software, SAS 
Structural Equation Modeling for JMP provides a graphical user interface (GUI) that enables you to build a model 
graphically, uses PROC CALIS to analyze the model, and displays the results on the GUI.  

A typical scenario for a SEM user is to specify a model, analyze it for fit, and iteratively make minor changes to the 
model to see if the fit improves. To facilitate this process, the SAS Structural Equation Modeling for JMP user 
interface is designed to make it easy to specify a model, to duplicate a model, and to switch back and forth between 
results for several models. You can use a model specification repeatedly, with different sets of data, and also create a 
model specification before data are available.  

SAS STRUCTURAL EQUATION MODELING FOR JMP WINDOWS 

SAS Structural Equation Modeling for JMP provides the following windows for working with models: 

 The Single-Group Analysis window enables you to create models, analyze them, and store results for later 

use.  

 The Model Library window enables you to create models either with or without data and store them. 

However, you cannot use this window to perform an analysis. You analyze these models with the Single 

Group Analysis window.  

 The User Profile window enables you to set preferences and default settings that are used by the Single 

Group Analysis and Model Library windows.  
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MODEL SPECIFICATION 

Creating models is an important aspect of SEM. The ability to define a model specification graphically is very helpful, 
especially when you have a model that consists of a number of interrelated variables.  

A model specification consists of variables and relationships among variables. The variables might include latent 
variables in addition to observed variables. Relationships can be one-directional, such as regression coefficients, or 
two-directional, such as covariances and correlations. 

An example of a simple model specification is the variable X predicting the variable Y. This model specification is 
represented by a one-directional relationship from X to Y as shown by the top pair of variables in Figure 1.  A 
correlational relationship is represented by a two-directional relationship between X and Y as shown by the bottom 
pair of variables in Figure 1. 

Figure 1. Two Simple Models 

 

The example shown in Figure 2 has three variables: X, Y, and Z. You believe that X influences Y, so you create a 
one-directional relationship from X to Y. You believe that Y influences Z, so you create a one-directional relationship 
from Y to Z. You do not believe that X has a direct effect on Z, so you do not create a relationship between X and Z. 

Figure 2. Another Simple Model 

 

GRAPHICAL MODEL BUILDING 

The graphical model builder in SAS Structural Equation Modeling for JMP consists of a diagram-drawing area and 
several tools for defining model specifications, as shown in Figure 3. To define a model, you add variables to the 
diagram and define relationships among variables. You also define properties for the variables and the relationships. 
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Figure 3. Diagram and Tools 

 

ADDING VARIABLES 

You can add variables to a diagram in any of the following ways: 

 Drag a rectangular or oval shape from the palette shown in Figure 3 to the diagram. You must provide a 

variable name as one of the variable properties. 

 Display a context menu by right-clicking on the diagram and selecting Add observed or Add latent from the 

menu. You must provide a variable name as one of the variable properties. 

 Drag a variable name from the variables list shown in Figure 3 to the diagram or to a variable already in the 

diagram. The variable name of the new variable is automatically set. If you drag a variable name to a 

variable in the diagram, the variable is created and a one-directional relationship is drawn between the two 

variables. By default, the arrow is drawn from the variable already on the diagram to the new variable. This 

direction is a preference that you can change. 

Rectangles represent observed variables, and ovals represent latent variables. The shapes that represent observed 
and latent variables are preferences that you can change. 
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DEFINING RELATIONSHIPS 

A relationship between two variables can be one-directional or two-directional. To define a relationship, position the 
cursor over the variable from which you want to draw the relationship. A pop-up palette of relationships represented 
by arrows is displayed as shown adjacent to the X variable in Figure 4. 

Figure 4. Arrows Palette 

 

 To define a one-directional relationship, select the one-directional arrow from the arrows palette, and drag 

the arrow to the other variable. 

 To define a two-directional relationship, start with either variable, select the two-headed arrow from the 

arrows palette, and drag it to the other variable. 

SETTING PROPERTIES 

Variables have the following properties: the variable name, a label, a variance parameter, and a mean parameter. To 
set the properties for a variable, either double-click the variable shape or right-click the variable shape in the diagram 
and select Set variable properties from the pop-up menu. A properties dialog box appears. Figure 5 shows the 

properties dialog box for observed variables. 

Figure 5. Observed Variables Properties Dialog Box 
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The variable name is required. For an observed variable, it is the name of the variable in the data set being analyzed. 
For a latent variable, it is a valid variable name that is distinct from all variables in the data set being analyzed. A valid 
variable name consists of a letter or underscore followed by letters, digits, or underscores; it must be unique from 
other variable names within the first thirty-two characters. Variable names are case-insensitive. 

You can provide a label that differs from the variable name. It is used in the diagram but not in the analysis results. 

The variance and mean parameters can either be a fixed value or a parameter to be estimated. If estimated, you can 
optionally specify a parameter name and an initial value.  Like a variable name, a valid parameter name consists of a 
letter or underscore followed by letters, digits, or underscores and must be unique from other parameter names within 
the first thirty-two characters. Parameter names are also case-insensitive. 

The relationships between variables also have properties.  To set the properties for a relationship, right-click the 
arrow that represents the relationship between two variables.  From the pop-up menu, select Set path properties for 
a one-directional relationship or Set covariance properties for a two-directional relationship. A dialog box for the 
selected relationship appears; Figure 6 shows the dialog box that appears when you select Set path properties. 

Figure 6. Path Properties Dialog Box 

 

Both a path and a covariance can be either a fixed value or a parameter to be estimated.  As is the case for variances 
and means, if it is estimated, you can optionally specify a parameter name and an initial value. You are not required 
to provide a parameter name for variances, paths, covariances, or means; if you do not provide a parameter name, a 
unique one is created for you.  

If you want to constrain a parameter to be the same for several paths, use the same parameter name for all those 
paths. You can do the same for parameters for covariances, variances, and means. For example, if you want to 
constrain the variance for three variables to be the same parameter, select all three variables, open the properties 
window, and edit the variance properties. The variance information you provide in the properties window is used for 
all three variables. 
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Figure 7 shows an example of a model with two latent variables and eight observed variables. 

Figure 7. Example of a Model Specification 

 

CUSTOM VIEWS FOR THE DIAGRAM 

You can see one or more custom views by right-clicking in the diagram area and selecting the custom view from the 
pop-up menu. Figure 8 shows the three custom views. 

Figure 8. Custom Views for Error Variables, Variance Paths, and Default Covariances 

 

 You can show explicit error variables for each endogenous variable by selecting Show error variables from 

the pop-up menu. Figure 8 shows an error variable for the eu2 variable. 

 You can show explicit variance paths by selecting Show variance paths from the pop-up menu. The 

variance path is represented by a double-headed arrow to and from the same variable. Figure 8 shows 
variance paths for the eu1, pu1, and error variables. 

 You can show the assumed covariances between exogenous variables by selecting Show default 
covariances from the pop-up menu. These covariances are estimated even if you do not specify them. 

Figure 8 shows a default covariance between the eu1 and pu1 variables. 
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SINGLE-GROUP ANALYSIS WINDOW 

A single-group analysis involves fitting a structural equation model to a single sample. Inferences are drawn for a 
single population. In contrast, a multiple-group analysis involves more than one sample. Multiple-group analysis can 
be performed using the CALIS procedure, but it is not available in the first release of SAS Structural Equation 
Modeling for JMP. 

The Single-Group Analysis window enables you to create and analyze one or more model specifications, view the 
results, and save the properties and results of the analyses as a SEM project for later use.  

From the main JMP menu, select Analyze►Structural Equation Modeling►Single Group Analysis. The Single-

Group Analysis window appears; see Figure 9. The window is organized in three tabs:  

 Use the Data tab to specify characteristics of the data that are to be used by all analyses. 

 Use the Analyses tab to create model specifications, specify analysis methods, and view analysis results. 

 Use the Comparisons tab to compare fit statistics for the analyses in the project. 

Figure 9. Single-Group Analysis Window 
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DATA TAB 

The Data tab is shown in Figure 10. The current JMP data table is used, and its name is listed in the Data Table 
Properties group box. SAS data sets can be opened as JMP tables.  

Figure 10. Data Tab 

 

You can analyze either raw data or covariances or correlations. Raw data consist of variables that are organized as 
columns with values of individual observations arranged in rows. Covariances or correlations are arranged in a data 
set in matrix form as shown in Figure 11. Select either Raw data or Covariances, correlations from the Data 
structure list.  

Figure 11. JMP Data Table That Contains Covariances 

 

Statistics and Data AnalysisSAS Global Forum 2011

 
 



Introducing SAS Structural Equation Modeling for JMP, continued 

 

9 

The correlations or covariances must conform to a specific structure. The data table must contain two variables: 
_name_ and _type_. It must also contain a specific JMP data table property: SASTYPE. The value of the SASTYPE 
variable must be either COV or CORR.  

If the data set does not contain the appropriate structure, you must create the variables and data table property with 
the appropriate values. An example of a data table that contains covariances in the appropriate structure is shown in 
Figure 11. 

In some circumstances, the Single-Group Analysis window can determine that the data table contains a covariance or 
correlation matrix and automatically supply the required variables and SASTYPE property. The most likely case is a 
data table that contains the same number of rows as the number of numeric variables. For example, with the data 
table as the current JMP data table, open the Single-Group Analysis window. On the Data tab, the Data Structure 
list is set to Raw data by default. From the Data Structure list, select Covariances, correlations. A dialog box is 

displayed that indicates that the data set does not have the necessary structure and asks whether you want the 
application to provide the appropriate variables to correct the problem. If you answer Yes, you are asked whether the 

input data set contains covariances or correlations. The necessary information is added to the data table. 

The values of the _name_ variable must contain the name of the variable for the corresponding row. For example, the 
value for the second row of the eu1 variable is 0.343. It is the covariance between the eu1 and eu2 variables. 

The values of the _type_ variable must contain the value COV or CORR, which indicate that the values for the 
variables in that row are covariances or correlations, respectively. A value of N for the _type_ variable indicates a row 
of the number of observations, and a value of MEAN indicates a row of means. 

If the data table contains covariances or correlations and does not contain a number of observations row, use the 
Number box on the Data tab to specify the value. You can also control the degrees of freedom for the analysis by 
selecting the Use instead of the actual number of observations check box and specifying the appropriate value in 
the Number box. 

If the data set contains a frequency variable, select the name of the variable in the Select Columns list and either 
click Frequency or drag the variable into the field beside Frequency. 
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ANALYSES TAB 

Use the Analyses tab to create one or more analyses. An analysis consists of a model specification, a selection of 

analysis methods, and after the analysis has been performed, several results. These are arranged as tabs within the 
Analyses tab as shown in Figure 12. 

Figure 12. Analyses Tab 

 

Creating and Running an Analysis 

To create an analysis, click New beneath the Analyses list to the left of the diagram. The name of the analysis 
appears in the Analyses list. The first analysis in a SEM project is automatically created for you and named “Analysis 
1”. You can change the name of the analysis and add notes on the General tab. 

You can create a model specification on the Diagram tab in any of the following ways: 

 Use the graphical model builder as described in the section “Graphical Model Building.” 

 Copy a model specification from the Model Library by clicking Model Library and selecting Get a model. 

 Copy an existing analysis by clicking Copy. Copying an analysis also copies the analysis methods. 

Select the appropriate analysis methods on the Methods tab. 

Perform the analysis by clicking Run. When the analysis has been run, the Results, SAS Log, and SAS Code tabs 
appear beside the Diagram, General, and Method tabs as shown in Figure 13. 
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Figure 13. Analysis Results 

 

Several views of the model are available on the Diagram tab: 

 The input view shows the input specification including the variable names or labels and any information that 
you specify about the paths, covariances, variances, and means. You use this view to create a model 
specification. Select Input from the View list. 

 After an analysis is run, the unstandardized parameter estimates for paths, covariances, variances, and 
means are displayed. Select Unstd. Estimates from the View list. The unstandardized estimates are shown 

in Figure 14. 

 Also, after an analysis is run, the standardized parameter estimates for paths, covariances, and variances 
are available. Select Std. Estimates from the View list. 
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Figure 14. Unstandardized Estimates 

 

 

Creating Additional Analyses 

You can create additional models by clicking New under the Analyses list. You can also copy the model of an 
existing analysis by clicking Copy. Copying an analysis also copies the analysis methods. 
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COMPARISONS TAB 

You can compare the results of several analyses in a SEM project. To compare models, select the Comparisons 

tab. A table of fit statistics is displayed for all analyses in the project, as shown in Figure 15. You also can customize 
which fit statistics you want to appear in the table.  

Figure 15. Comparisons Tab 

 

SAVING AND OPENING SINGLE-GROUP ANALYSIS PROJECTS 

You can save the analyses that you have created as a single-group analysis project in a single JMP project file.  Click 
Save or Save As to save the project. You can view or edit the single-group analysis project at another time by 
clicking Open and selecting the project file. Name your single-group analysis project files so that you can distinguish 

them from other JMP project files and SEM model files which are described in the section “Saving Model Projects.” 
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MODEL LIBRARY WINDOW 

The Model Library window enables you to create a model specification, but you cannot use this window to perform an 
analysis. You must use the Single-Group Analysis window to analyze models. In the Model Library window you can 
optionally choose to use the variables that are contained in the current JMP data table. However, a data table is not 
required, so you can use the Model Library window to create all or part of a model specification without access to the 
data. To open the Model Library widow, select Analyze►Structural Equation Modeling►Model Library from the 

main JMP menu. The Model Library window is shown in Figure 16. 

Figure 16. Model Library Window 
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CREATING AND OPENING MODEL SPECIFICATIONS 

You can create a new model specification or open an existing model specification for editing or viewing: 

 To create a new model, click New. If a data table is open in JMP, you are asked whether you want to use 

the names of the variables in the current JMP data table. Variable names are useful for dragging onto the 
diagram to create a model. 

 To open an existing model, click Open. Select the model project file that you want to open. 

 To create a model specification, use the graphical model builder as described in the section “Graphical 
Model Building.” 

SAVING MODEL PROJECTS 

You can save a model specification as a SEM model in a single JMP project file. Click Save or Save As to save the 
project.  Name your model project files so that you can distinguish them from other JMP project files and single-group 
analysis project files described in the section “Saving and Opening Single-Group Analysis Projects.” 
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USER PROFILE WINDOW 

You can use the User Profile window to set preferences for the Model Library and Single-Group Analysis windows.  

From the main JMP menu, select Analyze►Structural Equation Modeling►User Profile.  The User Profile window 

is organized in several tabs as shown in Figure 17.  

Figure 17. User Profile Window with Diagram Tab 

 

Changes in preferences do not take effect until the User Profile is closed and the Model Library window or Single-
Group Analysis window is next opened. 

As shown in Figure 17, the Diagram tab shows several preferences that you can select for creating a model 

specification in both the Model Library and Single-Group Analysis windows. You can use either a circle or an oval to 
represent a latent variable and a rectangle or a square to represent an observed variable. 

When you drag a variable name from the variables list to a variable shape in the diagram, the variable is created in 
the diagram and a path is drawn between the variable that was dragged and the variable that was the target of the 
drag. The Arrow Direction preference enables you to specify whether you want the arrow to be drawn from the 

target variable to the new variable or from the new variable to the target variable.  

The Fit Indices tab lists the fit indices that are displayed in the results table, as shown in Figure 18. For each fit index 
that you want displayed on the Results tab of the Single-Group Analysis window, select the corresponding check 

box. Clear the check boxes that correspond to any selected fit indices that you do not want displayed. 
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Figure 18. User Profile Window with Fit Indices Tab 

 

The Methods tab contains options for the Single-Group Analysis window. You can choose to analyze the correlations 

or covariances. If you are analyzing covariances, you can choose to analyze mean structure. You can also choose 
from several estimation and optimization methods. 

SYSTEM REQUIREMENTS AND INSTALLATION 

SAS Structural Equation Modeling for JMP is available for PCs that run the Microsoft Windows 7, XP, and Vista 
operating systems.  It requires JMP 9.0.2 or later and SAS/STAT 9.22 or later.  You can use SAS software that is 
installed on your PC, or you can access it from a remote machine.  

SAS Structural Equation Modeling for JMP and JMP software must be installed on the client machine. The installation 
of SAS Structural Equation Modeling for JMP occurs automatically if Foundation SAS is installed on the client 
machine. If you are using SAS from a remote server, you must use the SAS Deployment Wizard to install SAS 
Structural Equation Modeling for JMP on the client machine. The order of the JMP and SAS Structural Equation 
Modeling for JMP installations is not important. 

CONCLUSION 

SAS Structural Equation Modeling for JMP combines the power of SAS/STAT software with the JMP user interface to 
provide a new user interface that makes creating and analyzing structural equation models easy. You can use its 
graphical model builder to efficiently create models. You can perform a single-group structural equation model 
analysis and save the results for later use. 
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