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ABSTRACT

SAS Enterprise Guide allows you to define parameters, and then use those parameters in your project. Parameters
are simply macro variables. When you run a project containing parameters, SAS Enterprise Guide prompts you to
assign values to those macro variables. Using parameters, you can create a project, and then customize it at the time
you run it.

In SAS Enterprise Guide 4.1, there are three ways to use parameters: as a variable name in a task, in the filter
condition of a query, or in SAS code. This paper covers all three types of parameters, showing how to define
parameters, how to insert them in your project, and then how to run the final project using the parameters.

INTRODUCTION

Subsetting data and running reports is easy in SAS Enterprise Guide. It is also easy to reopen a query or task, make
a change, and then rerun your project. But making changes can be even easier if you use parameters. With
parameters, you don’t have to reopen the query or task to make changes. You just run the project, and SAS
Enterprise Guide will prompt you for the changes.

This paper starts with a simple project consisting of a task, a query, and SAS code—without using parameters. Then
we create parameters, and add them to the task, query and code.

RUNNING A LIST REPORT WITHOUT PARAMETERS

The examples in this paper use a data table named World, which contains data about all the countries in the world.
To create a simple detail report, click the data icon in the Project Explorer or Project Designer to make it active, and
select Describe » List Data from the menu bar. The List Data window will open.
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In the List Data window, assign variables (also called columns) to task roles.
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To specify a title for the report, click Titles in the selection pane on the left. Then uncheck the Use default text
option, and type the new titles in the box below. When you are satisfied, click Run.
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The new list report will appear in the workspace.
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FILTERING DATA IN A QUERY WITHOUT PARAMETERS
To open the Query Builder, right-click the data icon in the Project Explorer or Project Designer and select Filter and
Query from the pop-up menu. You can also click the data icon to make it active, and then select Data » Filter and

Query from the menu bar.
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In the Query window, highlight all the columns (also called variables) that you want to keep in the subsetted data
table, and drag the column names to the Select Data tab. If you want to keep all the columns, you can drag the data
table name instead.
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Then click the Filter Data tab. Click the column you want to use for subsetting the data, and drag it to the Filter Data
tab. In this example, the column YearInd is being dragged to the Filter Data tab. The Edit Filter window will open.
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In the Edit Filter window, specify an Operator and Value. In this example, the operator is set to Greater than or
equal to, and the value is set to 1990 so this filter will select all countries that became independent on or after 1990.
When you are satisfied with the settings, click OK to return to the Query window.
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The Filter Data tab in the Query window will display the new filter. Click Run and SAS Enterprise Guide will run the
query and display the results in a Data Grid.
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The new data table in this example includes only the 27 countries that have become independent since 1990.
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RUNNING SAS CODE WITHOUT PARAMETERS

To open an empty Code window so you can write a SAS program, select File » New » Code from the menu bar. Then
type your program using the syntax-sensitive editor.

Eag Project Designer | [£] Code®

=IPROC FRE(Q DATAL = 'c:'My3hsdatah Torld':
WHERE ¥earInd >= 1990;
TABLES Region:
TITLE]1l "Countries That Became Independent in 1990 or Later™:
TITLEZ "For Each WValue of BEegion®:
RUH;




To run the code, click the code icon to make sure it's active, and select Code » Run program-name On server-
name from the menu bar where program-name is the name of your program (such as Code), and server-name is the
server you want to run SAS on (such as Local). The results will appear in the workspace. Note that in this case you
could accomplish the same result without writing any SAS code by using a query to subset the data, and then using
that data as the input for a One-Way Frequencies task.

& SAS Enterprise Guide - ParametersHOW

File Edit wew Code Data Describe Graph  Analvze  Add-In OLAP  Tools  Window  Help

Er S B e D K o 0, | BogProjert Designer [T Masimize Workspare E7 Task Status

World (Process Flow) L -
| Bog Froject Designer | [£] Code | 42 HTML-Code | % |y
%S:'a;:gi? g:v Countries That Became Independent in 1990 or Later - %
= %i%f B bate For Each Value of Region :
% tZZ[ . The FREQ Procedure

@ HTML - List Dtz

=5 Query for wWorld
[£] Last Submitted Code Cumulative Cumulative
[£] Log Region Frequency Percent Frequency Percent
E_?_i Queny_for world
=-[#] Code Africa 2 7.41 2 T7.41
Ia Log
B HTML - Code Asia 9 33.33 11 40.74
Australia/Pacific 1 3.70 12 44.44
Europe 15 | 55.56 27 100.00 =

Task Status Queue | Server

<

|+

Ready rl [Unknown] connected ta localhost

We now have a simple project consisting of a data table, a List Data task, a query, and SAS code. We are ready to
add parameters.
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CREATING PARAMETERS FOR VARIABLE NAMES

To create a variable name parameter that can be used in a task, first open the Parameters Manager by selecting
Tools » Parameters (Macro Variable) Manager from the menu bar. In the Parameters Manager, click Add to open

the Add New Parameter window.
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In the General tab of the Add New
Parameter window, you specify a Display
name, a SAS code name, and a
Description, and then choose the Data
type from a pull-down list. The display
name is the text you will see when you run
the task. The SAS code name will be the
name of your macro variable. The SAS
code name must be 32 characters or fewer
in length; start with a letter or underscore;
and contain only letters, numerals, or
underscores. The description is optional
and appears only in this window.

In this example, the display name is Select
a Grouping Variable for the Report, the
SAS code name is GroupingVariable, and
the data type will be Variable name.
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The new parameter will appear in the Parameters Manager window. Click Close.
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USING PARAMETERS IN TASKS

To use a parameter in an existing task, reopen the task by double-clicking the task icon in the Project Explorer or
Project Designer. In the task window, the list of variables will now include any variable name parameters. You can tell

. . - . . &
which variables are parameters because their icons include a little ampersand symbol ﬂ-} You can drag the
parameters to task roles just like other variables.
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You can also use parameters in titles and footnotes. To specify a title for the report, click Titles in the selection pane
on the left. Then uncheck the Use default text option, and type the new titles in the box below. When you type the
parameter name into a title, you must put an ampersand in front of its name. In this example, the parameter name is
&GroupingVariable. When you are satisfied, click Run.
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A window will open prompting you to choose a value for the parameter. Choose the value for the parameter, and click
Run. In this case, LandGroup was chosen, but you could choose some other variable name from the list.
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The results will be displayed in the workspace.
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CREATING PARAMETERS FOR DATA VALUES
To create a parameter that can be used in the filter condition of a query, first open the Parameters Manager. You can

do this inside the Query window by clicking the Parameters button, or from the menu bar by selecting
Tools » Parameters (Macro Variable) Manager. The Parameters Manager will display any parameters that have
already been defined for this project. In the Parameters Manager, click Add to open the Add New Parameter window.
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Your new parameter will now be listed in the Parameters Manager. Click Close.
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USING A PARAMETER IN THE FILTER CONDITION OF A QUERY
To use a parameter in an existing query, open the Query window by double-clicking the query icon in the Project
Explorer or Project Designer. In the Query window, click the Filter Data tab and click the Edit Filter button on the right

side. g The Edit Filter window will open.
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In the Edit Filter window, click the down-arrow on the Value box. Click the Parameters tab, and select the name of

the parameter you want to use.
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The parameter name will now be listed in the Value box. Click OK.
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The new filter using the parameter will be displayed in the Query window. Click Run to rerun the query.
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When you run the query, a window will open prompting you to specify a value for the parameter. In this example, 1950
has been typed in. When you are satisfied, click Run and SAS Enterprise Guide will run the query using the value you
specified.
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The results of the query will appear in a Data Grid. In this example, the new data table contains the 113 countries that
have become independent since 1950.

& SAS Enterprise Guide - ParametersHOW

File Edit ‘iew Code Data Describe Graph  Analyvze  Add-In OLAP  Tools  window  Help
= [&" - % 3 %= By B X > Wic S N gqg Project Designer E| Maximize Workspace % Task Status
Query_for_world (Query For world (P = oo,
Project Explore [%] 5 .
lﬁ m Eon Project Designer | (=] Query_for_World [read-onk) | x|
,F'arametersHDW @ Country @ Region @ Yearlnd |{5_"\> IndGroup @ 5 Q
rem Process Flow - . e
g Eﬂ world 1 Algena Africa 1962 1945 ta present 5
E] List Diata 2 Angola Africa 1975 1946 to present o
i 3 Artigua and Barb  Morth &merica 1981 : 1946 to present
g Last Submitted Code : .
I% Log 4 Armenia Aszia 1991 1946 to present
& HTHL - List Data 5 Azerbaijan Az 1991 194 to present
= E§ Query for Waorld B Bahamas, The Morth America 1973 1946 ta present
m Last Submitted Cade T Bahrain Azia 1971 1946 to present
% Log 8 Bangladesh Asia 1971 1946 to present
Eﬁ Gluery_for_"world 9 Barbadoz Morth Amnerica 1966 | 1946 to present
=] E’ﬂ Code 10 |Belarus Europe 1991 1946 to present
[E] Log 11 |Belize Marth Arerica 1991 1946 to present
@ HTML - Code 12 |Benin Africa 1960 1946 to present
13 |Bosnia and Herze  Ewnope 1932 1945 to present
14 |Botswana Africa 1966 1946 to present L
< | >
k Stal [%]
Tazk Statuz Queue | Server
3 EJ|E |
Ready rl [Unkhawi] connected to localhost

USING PARAMETERS IN SAS CODE

To reopen an existing code file, double-click its icon in the Project Explorer or Project Designer. Then edit the code. In
this example, the parameters &StartingYear and &GroupingVariable have been added to the program. Notice that
this is just a normal SAS program that uses macro variables.

Beg Project Diesigner | [£] Code®

=IPROC FREQ DALTA = 'c:'My3hsSdatah Torld':
WHERE YearInd »>= &3tarting¥ear:
TABLES &GroupingWariable:
TITLE1l "Countries That Became Independent in &3tarting¥Year or Later™;
TITLEZ "For Each Value of £CGroupingVarisble™:
RUNH:
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When you create parameters in the Parameter Manager and then use them in code, you need to associate the
parameters with the code. To do that, right-click the code icon in the Project Explorer or Project Designer, and select

Properties. Then, in the Properties for Code window, click Parameters in the selection pane on the left, and click the
Add button. This opens the Select Parameters window.

] Properties for Code

Gerneral Parameters
Results

Project parameters used:

Summary

545 MName Dizplay Mame Data Type

Thig item doez not uze any parameters that are defined in the project,

Click
Parameters

< E

Add... k Remowe Farameter Manager...
Azgociates existing parameters with the code,
| ] Mare (F1)...

[1]8 H Cancel l

The Select Parameters window lists all the parameters currently defined in the project. Use control-click to highlight
the names of all the parameters you want to use in the code. Then click OK.

1 Select Parameters

Select additional parameters to uze:

Select
parameters

0K Q[ Cancel IA
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The parameters will appear in the Properties for Code window. Click OK.

] Properties for Code

General Parameters
Results
Parameters .
Project parameters used:
Summary
545 MName Dizplay Mame Data Type
Groupingtfariable  Select a Grouping W ariable for the...  Yariable name
Starting''ear Select Countriez Independent Sin...  Integer
< L

Add... Remowe Farameter Manager...

Saves pour changes and clozes thiz window,

| ] Mare (F1)...

[ 1] %_H Cancel l

To run the code, click the code icon to make sure it's active, and select Code » Run program-name On server-
name from the menu bar. When you do this, a window will open prompting you to select values for each parameter.
After you have set the values for the parameters, click Run.

Ef Select values for these parameters

Select a Grouping ariable for the Fepart |F|egion v| =

Select Countriez Independent Since vear 1950

Jsas Rur N[ Cahicel ]A
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The output from the SAS code will appear in the workspace.

& SAS Enterprise Guide - ParametersHOW

File Edit Wiew Code Data Describe  Graph  Analyze  Add-In OLAP  Tools  Window  Help
=R E”', - % & 2 Hy [ 2 M | < . sug Project Designer E|Ma><imize ‘Workspace ﬁTaskStatus .
Query_for_world (Query for world (P~ FoE .

Froject Eaplorel.,. ... [ fog Project Diesigrer ‘ (& HTML-Code | * |E
E ParametersHOW =l
i=-Beg Process Flow Countries That Became Independent in 1950 or Later =

= EEE whorld N =
=-TH List Data For Each Value of Region
[Z] Last Submitted
] Lo The FREQ Procedure
:g HTHL - List Dratz Q
=5 Query forword
E] Last Submitted Cade Cumulative Cumulative
Z] Log Region Frequency Percent Frequency Percent
EEE Guery_for_\World
=[] Code Africa 43 43.36 43 43.36
@ Log
[ HTML -Code Asia 22 19.47 71 62.23
Australia/Pacific 13| 11.50 84 74.34
Europe 186 14.1¢ 100 88.50
Nerth America 11 9.73 111 98.23
South America 2 1.77 113 100.00
w
e[|
Task Statuz Queue | Server
13 >
Ready rl [Unknown] connected to localhost

CONCLUSIONS

Using parameters in SAS Enterprise Guide allows you to create projects that are flexible. First you use the
Parameters Manager to define your parameters. Next you insert the parameters into tasks, queries, or SAS code.
Then every time you run the project, a window will open prompting you to select values for the parameters.
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