Dynamic Projects in SAS® Enterprise Guide®
How to Create and Use Parameters
Lora D. Delwiche, University of California, Davis, CA
Susan J. Slaughter, Avocet Solutions, Davis, CA

ABSTRACT
SAS Enterprise Guide allows you to define parameters, and then use those parameters in your project. Parameters are simply macro variables. When you run a project containing parameters, SAS Enterprise Guide prompts you to assign values to those macro variables. Using parameters, you can create a project, and then customize it at the time you run it.

In SAS Enterprise Guide 4.1, there are three ways to use parameters: as a variable name in a task, in the filter condition of a query, or in SAS code. This paper covers all three types of parameters, showing how to define parameters, how to insert them in your project, and then how to run the final project using the parameters.

INTRODUCTION
Subsetting data and running reports is easy in SAS Enterprise Guide. It is also easy to reopen a query or task, make a change, and then rerun your project. But making changes can be even easier if you use parameters. With parameters, you don't have to reopen the query or task to make changes. You just run the project, and SAS Enterprise Guide will prompt you for the changes.

This paper starts with a simple project consisting of a task, a query, and SAS code—without using parameters. Then we create parameters, and add them to the task, query and code.

RUNNING A LIST REPORT WITHOUT PARAMETERS
The examples in this paper use a data table named World, which contains data about all the countries in the world. To create a simple detail report, click the data icon in the Project Explorer or Project Designer to make it active, and select Describe ▶ List Data from the menu bar. The List Data window will open.
In the List Data window, assign variables (also called columns) to task roles.

To specify a title for the report, click Titles in the selection pane on the left. Then uncheck the Use default text option, and type the new titles in the box below. When you are satisfied, click Run.
The new list report will appear in the workspace.

FILTERING DATA IN A QUERY WITHOUT PARAMETERS
To open the Query Builder, right-click the data icon in the Project Explorer or Project Designer and select **Filter and Query** from the pop-up menu. You can also click the data icon to make it active, and then select **Data > Filter and Query** from the menu bar.
In the Query window, highlight all the columns (also called variables) that you want to keep in the subsetted data table, and drag the column names to the **Select Data** tab. If you want to keep all the columns, you can drag the data table name instead.

Then click the **Filter Data** tab. Click the column you want to use for subsetting the data, and drag it to the Filter Data tab. In this example, the column YearInd is being dragged to the Filter Data tab. The Edit Filter window will open.
In the Edit Filter window, specify an **Operator** and **Value**. In this example, the operator is set to **Greater than or equal to**, and the value is set to **1990** so this filter will select all countries that became independent on or after 1990. When you are satisfied with the settings, click **OK** to return to the Query window.

![Edit Filter Window]

The Filter Data tab in the Query window will display the new filter. Click **Run** and SAS Enterprise Guide will run the query and display the results in a Data Grid.

![Query for World: Query Builder]

New filter appears in Query window
The new data table in this example includes only the 27 countries that have become independent since 1990.

**RUNNING SAS CODE WITHOUT PARAMETERS**
To open an empty Code window so you can write a SAS program, select **File > New > Code** from the menu bar. Then type your program using the syntax-sensitive editor.
To run the code, click the code icon to make sure it’s active, and select **Code ➤ Run program-name On server-name** from the menu bar where program-name is the name of your program (such as Code), and server-name is the server you want to run SAS on (such as Local). The results will appear in the workspace. Note that in this case you could accomplish the same result without writing any SAS code by using a query to subset the data, and then using that data as the input for a One-Way Frequencies task.

We now have a simple project consisting of a data table, a List Data task, a query, and SAS code. We are ready to add parameters.
CREATING PARAMETERS FOR VARIABLE NAMES
To create a variable name parameter that can be used in a task, first open the Parameters Manager by selecting Tools ▶ Parameters (Macro Variable) Manager from the menu bar. In the Parameters Manager, click Add to open the Add New Parameter window.

In the Parameters (Macro Variables) Manager window, you specify a Display name, a SAS code name, and a Description, and then choose the Data type from a pull-down list. The display name is the text you will see when you run the task. The SAS code name will be the name of your macro variable. The SAS code name must be 32 characters or fewer in length; start with a letter or underscore; and contain only letters, numerals, or underscores. The description is optional and appears only in this window.

In this example, the display name is Select a Grouping Variable for the Report, the SAS code name is GroupingVariable, and the data type will be Variable name.
Click the Data Type and Values tab. Here you specify the Data value type and the appropriate data values. In this example, the data value type is A list of values. When you select a list of values as the data value type, new options will appear in the lower part of the window. In the section labeled Options on the right, you can choose the Variable type. The default variable type is Character. If you click the Load Values button near the bottom of the window and navigate to a data set, you will get a list of all the variables of that type for that data set.

In this example, all the character variables in the World data set have been listed in the section labeled Value List. The variable Country is unique and therefore would not make a good grouping variable. To delete a variable, highlight its name and then click the delete button. 

When you are satisfied with all the settings, click Add and Close.
The new parameter will appear in the Parameters Manager window. Click **Close**.

**USING PARAMETERS IN TASKS**
To use a parameter in an existing task, reopen the task by double-clicking the task icon in the Project Explorer or Project Designer. In the task window, the list of variables will now include any variable name parameters. You can tell which variables are parameters because their icons include a little ampersand symbol (≈). You can drag the parameters to task roles just like other variables.
You can also use parameters in titles and footnotes. To specify a title for the report, click Titles in the selection pane on the left. Then uncheck the Use default text option, and type the new titles in the box below. When you type the parameter name into a title, you must put an ampersand in front of its name. In this example, the parameter name is &GroupingVariable. When you are satisfied, click Run.

A window will open prompting you to choose a value for the parameter. Choose the value for the parameter, and click Run. In this case, LandGroup was chosen, but you could choose some other variable name from the list.
The results will be displayed in the workspace.

CREATING PARAMETERS FOR DATA VALUES
To create a parameter that can be used in the filter condition of a query, first open the Parameters Manager. You can do this inside the Query window by clicking the Parameters button, or from the menu bar by selecting Tools ▶ Parameters (Macro Variable) Manager. The Parameters Manager will display any parameters that have already been defined for this project. In the Parameters Manager, click Add to open the Add New Parameter window.
In the General tab of the Add New Parameter window, you specify a Display name, a SAS code name, and a Description, and then choose the Data type from a pull-down list. The display name is the text you will see when you run the query. The SAS code name will be the name of your macro variable. The SAS code name must be 32 characters or fewer in length; start with a letter or underscore; and contain only letters, numerals, or underscores. The description is optional and appears only in this window.

In this example, the display name is Select Countries Independent Since Year, the SAS code name is StartingYear, and the data type will be Integer.

Click the Data Type and Values tab. Here you specify the Data value type and the appropriate data values. In this example, the data value type is Any integer value is allowed, and the default value has been set to 1990. When you are satisfied with all the settings, click Add and Close.
Your new parameter will now be listed in the Parameters Manager. Click **Close**.

**USING A PARAMETER IN THE FILTER CONDITION OF A QUERY**

To use a parameter in an existing query, open the Query window by double-clicking the query icon in the Project Explorer or Project Designer. In the Query window, click the **Filter Data** tab and click the Edit Filter button on the right side. The Edit Filter window will open.
In the Edit Filter window, click the down-arrow on the **Value** box. Click the **Parameters** tab, and select the name of the parameter you want to use.

The parameter name will now be listed in the Value box. Click **OK**.
The new filter using the parameter will be displayed in the Query window. Click **Run** to rerun the query.

When you run the query, a window will open prompting you to specify a value for the parameter. In this example, **1950** has been typed in. When you are satisfied, click **Run** and SAS Enterprise Guide will run the query using the value you specified.
The results of the query will appear in a Data Grid. In this example, the new data table contains the 113 countries that have become independent since 1950.

**USING PARAMETERS IN SAS CODE**

To reopen an existing code file, double-click its icon in the Project Explorer or Project Designer. Then edit the code. In this example, the parameters &StartingYear and &GroupingVariable have been added to the program. Notice that this is just a normal SAS program that uses macro variables.
When you create parameters in the Parameter Manager and then use them in code, you need to associate the parameters with the code. To do that, right-click the code icon in the Project Explorer or Project Designer, and select Properties. Then, in the Properties for Code window, click Parameters in the selection pane on the left, and click the Add button. This opens the Select Parameters window.

The Select Parameters window lists all the parameters currently defined in the project. Use control-click to highlight the names of all the parameters you want to use in the code. Then click OK.
The parameters will appear in the Properties for Code window. Click **OK**.

To run the code, click the code icon to make sure it’s active, and select **Code > Run program-name On server-name** from the menu bar. When you do this, a window will open prompting you to select values for each parameter. After you have set the values for the parameters, click **Run**.
The output from the SAS code will appear in the workspace.

CONCLUSIONS
Using parameters in SAS Enterprise Guide allows you to create projects that are flexible. First you use the Parameters Manager to define your parameters. Next you insert the parameters into tasks, queries, or SAS code. Then every time you run the project, a window will open prompting you to select values for the parameters.

REFERENCES


ABOUT THE AUTHORS
Lora Delwiche and Susan Slaughter are the authors of The Little SAS Book: A Primer, and The Little SAS Book for Enterprise Guide 4.1 which are published by SAS Institute. The authors may be contacted at:

Lora D. Delwiche  Susan J. Slaughter
(530) 752-9321  (530)756-8434
lldelwiche@ucdavis.edu  susan@avocetsolutions.com

SAS and all other SAS Institute Inc. product or service names are registered trademarks or trademarks of SAS Institute Inc. in the USA and other countries. © indicates USA registration. Other brand and product names are trademarks of their respective companies.